Archive for the 'battery' Category

08
Sep
11

Failed 1005ha battery mod

In the end of 2009 I bought my Asus Eee pc 1005ha netbook. It’s pretty good for what it is designed for. Have no complaints, just that the cpu could be a newer Intel Atom model.(Which would support 64bits OS’ and some virtualization options.)

Having used it heavily for more than a year and not really trying to save my battery life, the same has gone down the drain. From the advertised 8 hours, 6 hours good use to now less than an hour. Time to buy a new one.

I saw some batteries with 7200 mAh at eBay. Almost double the power my original battery had, which was 4800mAh. And they were sold for $40! I ended up buying one.

After receiving the battery I plugged it in my netbook and turned it on with the power supply connected.
Weird. The charging light(orange) flashed but stayed off. The BIOS froze at ‘Checking NVRAM’ for some time, but eventually continued. Ubuntu and Windows XP did not recognize the battery.
First thought: defective.

I browsed to the manufacturers(AGPTEK) website and voila, the battery shown in the site was different than mine! Did not have the logo, the battery text was upside down, and the voltage should be 10.8V instead of the 11.1V my new battery had.

I contacted the seller and, of course, I would have to send the battery back, which would cost the equivalent of $30 for a $40 refund. Of course I didn’t. I ended up loosing the dispute date in eBay, or else I would have disputed the payment.

Meanwhile, I decided to buy one from Amazon. Same price, same manufacturer. Should be safe.

Nope, I was wrong. Exactly the SAME battery arrived. And with the same behavior. Now I had two paperweights which I could not really use to power my netbook.

I gave up and put up a bet, all or nothing. I would replace the cells from the old battery with the ones from one of the new batteries. If it worked, I would have a working battery with huge capacity, or else I would have no working battery at all.

After finally managing to open the cases of the two battery packs, which were by no means designed to be opened ever again, I finally dis-soldered the cells and swapped the 6 pack for the new 9 pack. Put it halfway together and inserted it into the netbook while connected to the power supply.
(I recommend using a drill and CAREFULLY cutting into the edges of the battery that have been sealed, or use a heated knife.)

YAY! The charging light turned on! Thats a good start. I left the netbook charging for a bit. I kept checking the

/proc/acpi/battery/BAT0/state
/proc/acpi/battery/BAT0/info

files for any changes or status indications. Nothing.

I disconnected the power supply to test the battery. And my netbook powered of instantly….
I tried it again and got the same effect. The battery was not giving any juice. CRAP.

I looked it over to check if I had done something wrong or if there was some kind of sensor which had been triggered. Nada.
Oh well, time to put my old cell pack back into the battery.
After re-soldering the contacts and sticking the heat sensor back to one cell I tried it….
The same. No power.

YAY. No working battery. I wrapped both in tape to keep the pieces together and put the away. Had no more patience to keep fiddling with them.

OBS.:
It could be that without charge the circuit looses it’s memory or locks. If someone should try this, keep the circuit charged at all times, connecting the new battery pack in parallel first and then removing the old one.

Since I still had to use my netbook and did want to have a little liberty of mobility, I ended up plugging the second battery pack into it. Would have to find a work around with the BIOS issue.

So I was using the netbook for a time and noticed the charging light was ON. Rebooted, still had the BIOS issue and the charging light was off.

I insisted using the new battery for a time, and it ended up working perfectly after a while. Has a very good duration!
I was very confused about the apparent symbiosis the battery made with my netbook.. seems they take a while to understand each other.

Pictures:

Comparison of the old/original and new/chinese(lol) battery casing.(Obviously the old one has ASUS written on it).

The cells from the original battery.

The cells from the Agptek battery.

Front of the new Agptek battery control circuit. Casing below is from the new battery as well.

Back of the new Agptek battery control circuit. The heatsensor can be seen.

Front of the original battery control circuit connected to the new batteries cells.

Backside of the original battery control circuit

My original battery put back together. Purple wire is a substitution of the sheet/slab which I had to cut.

Sorry if this post seems heavy. Open the images in a new tab and you’ll see why.

Hope this helps someone who had the same problem/idea as I had.

Advertisements



The Author

Older Ramblings

Tweets

Linux User Sig