Archive for the 'drivers' Category

03
Aug
11

Bluetooth TTL module and Murphy

I bought a new Bluetooth Serial TTL module at eBay for a project of mine, which I will probably documenting here.

It is from MDFLY, as can be seen in the pictures below. The model is RF-BT0417CB.

Since at the time I had not yet received my Arduino 2009, a friend of mine suggested I test it with his Bus Pirate v3.5(BP for short).

He had bought one but never really used it, so there were the two of us, trying to get the BP to work. It is accessed through serial through USB, so to talk to it we discovered that screen does emulate serial connections!

screen /dev/ttyUSB0 115200

(BAUD rate does not need to be 115200, could be any other probably, and device may not be /dev/ttyUSB0… check your dmesg)

Obs.: screen is a Linux program, not Windows. Deal with it or install Cygwin. ‘Ctrl+a, k, y’ kills the screen so you can close it if you need to(probably will).

After connecting, screen is black. Hit ENTER to have ‘HiZ>’ appear. Now we need to set the mode that the BP will operate, since it has many available features.

HiZ>m
1. HiZ
2. 1-WIRE
3. UART
4. I2C
5. SPI
6. 2WIRE
7. 3WIRE
8. LCD
9. DIO
x. exit(without change)

(1)>3
Set serial port speed: (bps)
1. 300
2. 1200
3. 2400
4. 4800
5. 9600
6. 19200
7. 38400
8. 57600
9. 115200
10. BRG raw value

(1)>5
Data bits and parity:
1. 8, NONE *default
2. 8, EVEN
3. 8, ODD
4. 9, NONE
(1)>
Stop bits:
1. 1 *default
2. 2
(1)>
Receive polarity:
1. Idle 1 *default
2. Idle 0
(1)>
Select output type:
1. Open drain (H=Hi-Z, L=GND)
2. Normal (H=3.3V, L=GND)
(1)>2
Ready
UART>

Explained:
UART is so the BP can comunicate through serial, 9600 is normally the default speed, most of the rest are default options, and I prefer to use the ‘Normal’ output type because my Bluetooth module is TTL.

You will also need to connect the pins of the BP to the module:

BP -> MODULE
GND->GND
+5V->+5V
MOSI->RX
MISO->TX

Now we need to set the BP to power the module:

UART>W
Power supplies ON

The modules LED should begin to blink. If it stays on steadily it means that the module is connected through Bluetooth to another device. If it is off.. recheck the previous steps.

UART>{
UART LIVE DISPLAY, } TO STOP

This sets the BP to listen to incoming serial data. If there is a stream of data that should not be, it usually means that the TX is not connected properly to the MISO pin or that the module is turned off.

To test the communication with the device, send “AT” to it with:

WRITE: “AT”
UART>
READ: 0x4F
UART>
READ: 0x4B

The AT command should return “OK”(O=0x4F, K=0x4B).
If this doesn’t happen, recheck the TX->MISO connection or the BAUD rate for the module may be wrong. Try setting the BAUD rate to other values by redoing the mode setup.
Note: the ‘b’ command for the BP sets the BAUD rate for the pc side communication, not the module side.

Now comes the ‘problem’. Somewhere I read that the command to set/see the BAUD rate of the device was “AT+BAUD1”. This actually sets the BAUD rate to 1200. Great!. The recommended setting is “AT+BAUD4”, which will set it to 9600.

Second problem. The Bluetooth module is kind of picky when sending a ‘complex’ command. “AT” should work at almost any place, “AT+…” will probably not.
As I showed above, sending “AT” will return “OK” but in hex, not as chars. When using “AT+BAUD4” or “AT+VERSION”(check the version), the hex numbers representing the string will be shown, and not characters, which is a pain.
Also, when sending and receiving data through other devices, the data will be shown as hex, which normally isn’t very practical.

You can run the BP in Macro mode.

UART>(0)
0.Macro menu
1.Transparent bridge
2. Live monitor
3.Bridge with flow control

2 and 3 can be used on to read. When pressing a key the exit the mode. So pretty useless for normal applications.
The ‘Transparent bridge’ mode connects you ‘directly’ to the module. In this mode you receive the characters normally, not in hex, but everything you write does not appear for you AND every char you send, is sent as you type, not after you press enter. So while “A” and then “T” will work and you will receive “OK” as an answer; “A”, “T”, “+”, and then the command will not work since apparently it takes to long for each char to reach the module, so the command is discarded and you don’t even receive the “OK” for the “AT” part.

19
Feb
11

Sharing Photosmart 7200 from ubuntu to win7 via smb

So, I had to format my mothers computer because the 30GB partition reserved for Windows 7 64-bits had less than 3GB free space, and nothing really removable.

Instead of being lazy and using gparted to fix the problem(which included removing a 30GB Windows XP partition and moving the current partition out of a logical section of the harddrive, I just backed up the games(Steam rocks!) and formatted the damn thing.

Of course, backing up 100GB of Steam games and then getting them back would be no easy task(12hours by the steam backup manager, spliting the games into DVD sized chunks).

After having reinstalled everything, I went to configure the printer which is connected at another computer and shared through samba on an ubuntu maverick. (It was working fine before I formatted the harddrive.)

I added the printer through the interface in windows, but a prompt asked me to select the correct driver. OF COURSE, the exact driver of the printer was NOT present. Only photosmart 8xxx or photosmart 3xxx.

Searching the internet, I found out that the driver only is installed through windows update. Great. I had to select a driver, which only was installed if the printer was selected as the correct model. Just great….

I saw some references about modifying the smb.conf and cupsd.conf but none of the tries worked. I discovered the printer could be shared by selecting the cups http interface in windows but cups did not allow remote connections, and I was not able to configure it otherwise.

I ended up grabing the printer and connecting it to the Windows 7 and installing the driver, removing the printer device and taking it back to the ubuntu computer.

Then the driver was available in the prompt. YAY.

Note: I did not need to do this before, because the first time I configured the printer, the computer sharing it was Windows XP and probably reports the driver correctly to windows 7.

UPDATE
And I formatted my windows machine again. Had the same problem AGAIN. Obvious…

But this time I think I solved it… I’m trying to as I’m writing this.
This time I shared the printer via CUPS. The samba loading before cups problem in ubuntu is at fault.

It is quite easy configuring the CUPS interface via http://localhost:631 and sharing it on the network. Fuck samba.

I added the printer via http://ubuntumaching:631/printers/printer_name and set a similar driver(Photosmart C7200).
Now, in Windows, go to the Devices and Printers window, right-click the printer in question and click the Printer properties.
In the Advanced tab, click the New Driver button. Then follow the wizard, using the Windows Update to update your drivers list. It will take a while.

Select your driver and voilá! The correct driver is installed!




The Author

Older Ramblings

Tweets

Linux User Sig